Jump to content
CCID Bug in MAC 10.14.1 Weiterlesen... ×
Melde dich an, um diesem Inhalt zu folgen  
ckk

FW 1.9.0: CCID-Problem mit gnupg2

Empfohlene Beiträge

Hallo,

 

Mit der FW 1.9.0 hat der wave CCID-Unterstützung bekommen (super!).

 

Nachdem gnupg2 einen internen CCID-Treiber besitzt habe ich probiert, den wave mit diesen zu verwenden. Leider scheint da aber etwas noch nicht ganz zu funktionieren:

gpg2 --version
gpg (GnuPG) 2.0.26
libgcrypt 1.6.3
[...]

gpg2 --card-status
gpg: selecting opengpg failed: Card reset required
gpg: OpenPGP card not available: Card reset required

(Ein Karten-Reset hat übrigens nicht geholfen).

 

Ich habe dann gemäß Debian bug report #814584 zum Debuggen eine .gnupg/scdaemon.conf mit folgendem Inhalt eingerichtet:

debug-level guru
debug-all
debug-ccid-driver
log-file /run/user/1000/scd.log # change UID=1000 here.
verbose

Ich habe die gesamte erstellte Log-Datei angehängt, aber hier mal ein interessanter Ausschnitt:

2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver: PC_to_RDR_IccPowerOn:
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   dwLength ..........: 0
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   bSlot .............: 0
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   bSeq ..............: 1
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   bPowerSelect ......: 0x00 (auto)
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   [0008]  00 00
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver: RDR_to_PC_DataBlock:
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   dwLength ..........: 0
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   bSlot .............: 0
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   bSeq ..............: 1
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   bStatus ...........: 65
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver:   bError ............: 7
2016-06-16 20:03:33 scdaemon[6953] DBG: ccid-driver: CCID command failed: Parameter error at offset 7

Leider kann ich das Ergebnis nicht interpretieren. Weiß jemand, ob das ein Problem mit der noch jungen FW 1.9.0 sein kann, oder doch noch ein Bug im CCID-Treiber von gnupg?

 

Grüße,

Christian
 

 

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen  

×