Zum Inhalt wechseln


VMWare WS12 + Win10 + CyberJack e-com plus


  • Bitte melde dich an, um zu antworten
1 Antwort auf dieses Thema

#1 mschnell

mschnell

    Neues Mitglied

  • Members
  • PIP
  • 2 Beiträge:

Geschrieben 24 April 2016 - 10:16 AM

Hallo zusammen,
 
bislang lief mein "CyberJack e-com plus" in einer VMware Workstation VM prima. Nach dem Update des Hosts von Windows 7 auf Windows 10 lässt sich der Leser mit StarMoney nicht mehr richtig ansprechen. Der Fehler besteht darin, dass Starmoney eine PIN-Eingabe als Fenster in der Anwendung öffnet, anstatt die Tastatur des Lesers zu verwenden.
 
Alte Konfiguration (funktionierte problemlos) mit VM "Host": Windows 7 64 Bit
Neue Konfiguration mit VM "Host": Windows 10 64 Bit
 
Unverändert:
  • VMware Workstation 12
  • Gast System: Windows 10 64 Bit
  • Leser: CyberJack e-com plus (Version mit Display + Tastatur per USB)
  • Starmoney 10
 
Getestet habe ich:
  • Installation der aktuellsten Treiber: Base Components 7.2.5 (sowohl auf dem VM "Host" als auch auf dem VM "Gast" System)
  • Auf dem Windows 10 VM "Host" funktioniert der Leser einwandfrei mit dem Test-Tool
  • Umgestellt auf "Ct API" im StarMoney Chipkartenleser Setup:  "Zugriff auf den Kartenleser fehlgeschlagen (-42)" (Nur "PC/SC" funktioniert halbwegs)
 
Auffällig ist, dass es nach dem Update des Host-Systems auf Windows 10 in der VM (Gast-System) jetzt zwei "Removable Devices" angezeigt werden:
  • Reiner SCT Kartensysteme cyberJack e-com plus
  • Shared REINER SCT cyberJack e-com plus USB 1 (Neu aufgetaucht nach dem Update)
Wenn man in der VM den ersten aktiviert (entspricht der alten Version vor dem Update), geht der Karteleser einfach aus. Wählt man den zweiten "Shared" Kartenleser in der VM aus, kann Starmoney den Leser finden, benutzt aber das "Pin Pad" nicht, sondern fragt nach der PIN im Applikationsfenster.
 
Im Windows "Gerätemanager" wird übrigens als "Smartcard-Leser" der "Microsoft Usbccid-Smartcard-Leser (WUDF) angezeigt. Laut einiger Internet-Foren müsste hier eigentlich ein Eintrag mit einem "Class 2" Leser vorhanden sein, der dann Tastatur-Unterstützung erlaubt (Keine Ahnung ob das so stimmt...).
 
Irgend eine Idee?
 
Cheers,
Michael


#2 mschnell

mschnell

    Neues Mitglied

  • Members
  • PIP
  • 2 Beiträge:

Geschrieben 30 April 2016 - 15:31 PM

Eine Deinstallation der VMWare Workstation 12 auf dem Windows 10 Host mit anschließender Neuinstallation hat das Problem behoben. Vermutlich ist ein Betriebssystemwechsel des Host Systems (in diesem Falls das Upgrade von Windows 7 auf 10) nicht so ohne weiteres möglich.