Jump to content
Achtung: Änderung bei Anmeldung im Forum! Weiterlesen... ×
WiPe

Cyber Jack Secoder OS X 10.11. El Capitan (Beta)

Empfohlene Beiträge

Hallo,

 

ich wollte gerade den aktuellen Treiber "pcsc-cyberjack_3.99.5final.SP07-universal-signed" auf OS X 10.11. Beta installieren, doch die Installation schlägt fehl.

Ich weiß, dass es sich bei El Capitan noch um eine Beta handelt, bei der die Treiber für Yosemite nicht funktionieren (können), was hier der Fall zu sein scheint. Gibt es vielleicht eine Möglichkeit, den Cyber Jack trotzden zum Laufen zu bringen?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo zusammen,

 

ich habe das Problem auch. Habe nun versucht, den Treiber von Hand in das vorgesehene Verzeichnis zu kopieren. Klappt nicht. Keine Berechtigung! Selbst via Terminal als root (oder Apple wheel) klappt das nicht. Offenbar scheint hier das neue Rechte- bzw. Systemdateischutzsystem von Apple zu greifen.

 

Tipp an ReinerSCT: Jetzt schon mal prüfen und passende Version entwickeln, sonst gibt es im Herbst keine Treiber - und das wäre sehr ärgerlich!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Frohe Nachricht, das Problem ist behoben.

 

Die Ursache für die Probleme ist die "System Integrity Protection" von El Capitan. Daran scheitert auch der Installer oder die manuelle Installation.

 

Hier die Lösung:

 

  1. OS X im Recovery Mode booten (cmd + r)
  2. "Security Configuration" von "Utilities" aufrufen 
  3. Die "System Integrity Protection" deaktivieren
  4. Nach dem Boot läuft die Installation ohne Fehler durch
  5. Noch einmal booten
  6. Freuen weil der Kartenleser wieder funktioneirt
  7. ggf. die "System Integrity Protection" wieder aktivieren

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo zusammen,

 

ich habe mir jetzt mal die Dev Doku von Apple angeschaut und da wird klar, dass der Ordner, der bisher vom RSCT-Treiber verwendet wird, nicht mehr für Drittanbieter nutzbar sein wird. Die Ordner /bin /usr und /sbin sind in Zukunft tabu. Als Alternative gilt laut Apple /usr/local - und wenn ich das richtig gelesen habe, werden während eines Updates auf OSX 10.11 alle in /usr liegenden Ordner, die nicht zum System gehören, automatisch nach /usr/local verschoben. 

 

Meine dringende Bitte an Reiner SCT: Bereits jetzt anfangen, den Treiber für OSX 10.11 zu entwickeln und ggf. auch zu einem offenen Beta-Test zur Verfügung zu stellen! Wer weiss, was bis zum Herbst sonst noch alles für Hürden in El Capitan auf uns warten!

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Frohe Nachricht, das Problem ist behoben.

 

Die Ursache für die Probleme ist die "System Integrity Protection" von El Capitan. Daran scheitert auch der Installer oder die manuelle Installation.

 

Hier die Lösung:

 

 

  • OS X im Recovery Mode booten (cmd + r)
  • "Security Configuration" von "Utilities" aufrufen 
  • Die "System Integrity Protection" deaktivieren
  • Nach dem Boot läuft die Installation ohne Fehler durch
  • Noch einmal booten
  • Freuen weil der Kartenleser wieder funktioneirt
  • ggf. die "System Integrity Protection" wieder aktivieren

Wie kann ich die security integrity protection deaktivieren, wenn ich El Capitan auf externer Festplatte installiert habe?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gleiches Problem hier,

 

aber ich kann meine Mühle nicht im Recovery Mode booten :(

 

Keine Idee warum. Cmd+R hilft nicht. Selbst mit kabelgebundener Tastatur.

Hat noch wer einen Tipp?

 

Wäre echt toll.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

 Security Configuration" von "Utilities" gibt es bei Mir im Menü nicht ? Kann Mir da einer ein Tip geben ?

 

 

und wenn Ich den Befehl sudo nvram boot-args="rootless=0"  bei Mir eingeben möchte das System ein Passwort haben was ich aber nicht eintippen kan ! weil ein Schloss davor ist 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich nehme mal an, dass Du noch nicht oft mit dem Terminal gearbeitet hast?! Wenn dort ein Passwort angefordert wird (seit neustem mit dem beschriebenen Schlosssysmbol), wird beim Eintippen nichts(!) angezeigt! Keine Sternchen, Kreis o.ä. - die Zeile bleibt einfach leer, das Passwort aber sehr wohl erfasst! 

 

Also beim nächsten Versuch einfach das Admin-Passwort eingeben und dann mit Enter bestätigen. Wenn keine Fehlermeldung kommt, sondern einfach eine neue Zeile, dann hat´s geklappt. Im Terminal gibt es nämlich auch oft keinerlei Rückmeldung!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Eine letzte Möglichkeit gibt es noch: Einfach mal beim Reiner SCT Support nachfragen, ob es schon einen Beta-Treiber gibt. Der sollte das Rootless-Problem dann ohnehin umgehen. Ansonsten hilft wohl leider nur warten, bis der Treiber veröffentlicht wird.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kurzes Update zu El Capitan Golden Master. Nach der Installation des GM ist der Treiber für den Chipkartenleser wieder deinstalliert.

 

Im Recovery Mode gibt es jetzt auch keinen Menüeintrag mehr, um die "System Integrity Protection" zu deaktivieren. Stattdessen ruft man im Recovery Mode das Terminal auf und gibt dort das nachfolgende Kommando ein:

 

csrutil disable

 

Nach dem Neustart funktioniert auch die Installation der Treibers wieder. Danach sollte man ein weiteres mal den Rechner im Recovery Mode starten und im Terminal das Kommando

 

csrutil enable

 

eingeben, damit die "System Integrity Protection" wieder aktiviert ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe gestern die Beta 3.99.5 Treiber unter El Capitan installiert. Auch hier muss erst die "System Integrity Protection" im Recovery Mode deaktiviert werden.

Nach der Installation war ein reboot nötig - erst dann wurde mein cyberjack comfort erkannt.

 

Allerdings läuft mein System jetzt recht instabil. Während dem Login Vorgang stürzt das System ab und an mal ab ... es braucht 2 - 3 Anläuft bis der Login erfolgreich geklappt hat ...

 

Werde daher die Treiber wieder deinstallieren und warten bis ReinerSCT saubere Treiber für El Capitan raus bringt .......

 

Das bringt mich zu der nächsten Frage :

 

Wie deinstalliere ich die Treiber unter Mac OS eigentlich ? :wacko:  

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kurzer Statusbericht:
ReinerSCT Support war so nett und hat mir per eMail die Beta-Treiber für El Capitain gemailt. Danke an den Support.
Diese Treiber lassen sich nun mit aktiven "System Integrity Protection" installieren.
Allerdings ist mein Mac danach immer noch sporadisch abgeschmiert ... meist dann wenn er sich in den Ruhezustand verabschieden wollte.

 

Löschen der alten Treiber laut Anleitung hat hier leider auch nicht geholfen. Zurückspielen eines TM-Backups war mir aber auch zu aufwändig.

Ich habe dann noch mal das Setup der El Capitain GM laufen lassen. Dabei bleibt das System unverändert, aber es werden scheinbar alle Dateien die laut "System Integrity Protection" nichts im System zu suchen haben gelöscht. Jedenfalls läuft bei mir alles wieder ohne Probleme und der Kartenleser funktioniert bisher tadellos ....
 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe heute vom reinerSCT-Support freundlicherweise die Betaversion Cyberjack_3.99.5final erhalten. Zunächst herzlichen Dank dafür. Ich konnte den Treiber trotz "SIP" installieren. Und bis jetzt läuft es. Mein iMac ist auch nicht abgeschmiert. Sollte sich daran was ändern, werde ich es posten...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gibt es inzwischen Treiber für El Capitan oder nicht? Wenn nicht, dann werde ich meinen cyberJack RFID basis wohl wandeln müssen. Auf der Verpackung befindet sich das apple-logo, welches suggeriert, dass es unter OSX läuft. Wohlgemerkt nicht unter einem antiquierten OSX, sondern unter einem aktuellen Betriebssystem. Gleichwohl denke ich nicht daran, im aktuellen Betriebssystem irgendwelche Änderungen vorzunehmen, soll heissen, das SIP wird von mir keinesfalls deaktiviert.

mfG

Peter Ruff

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Peter,

 

OS X 10.11 bringt einen eigenen CCID-Treiber (die Treibervariante, die für den cyberJack RFID basis benötigt wird) mit - Du findest ihn unter /usr/libexec/SmartCardServices/drivers/ 

Dieser Treiber enthält auch die nötigen Informationen für den cyberJack RFID basis. Ein Treiber von Reiner SCT sollte nicht notwendig sein (anders als für "richtige" cyberJacks). 

 

Viele Grüsse,

Isoleucin

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe mir aus der Website von REINERSCT den neuesten Treiber für OS X 10.11 installiert. Mein Gerät (cyberJACK komfort) funktioniert mit der neuesten Version von der AusweisApp2 (1.6.0) trotzdem nicht! 

 

Was ist hier los?

post-6250-0-77372900-1448977830_thumb.png

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi enzoreal,

 

hast Du Du mal getestet, ob der Kartenleser grundsätzlich funktioniert (pcsctest oder Creck)? Wenn der Kartenleser dort funktioniert, liegt es nicht primär am Treiber sondern eher an der Anwendung.

 

Viele Grüsse,

Isoleucin

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

 

an dieser Stelle nur an Reiner SCT die Bitte, zeitgemäße Crypto-Technik einzusetzen.

 

Die Developer-Mitgliedschaft bei Apple kostet pro Jahr 80 €. Da ist ein Zertifikat inclusive, mit dem man Installer signieren kann und die Benutzer nicht immer in den Systemeinstellungen bestätigen müssen, dass sie glauben, keinen Virus runtergeladen zu haben.

 

Um dieses Forum mit einem SSL-Zertifikat auszustatten, sind sogar nur 0 € fällig - z. B. bei https://www.startssl.com

Logins ohne SSL sind einfach nicht mehr Stand der Technik - und einer Firma im Security-Bereich nicht würdig.

 

Vielen Dank!

Andreas

post-6688-0-88946100-1449827123_thumb.png

post-6688-0-91146700-1449827364_thumb.png

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×